I'm having a problem with two Galaxy S5 phones that no one seems to able to fix. In 2016 I purchase two, new, unlocked, Samsung SM-G900T (T-Mobile) phones on Ebay. They were used on the Walmart Family Mobile (T-Mobile network) for a short time, but I ended up using them on Cricket (AT&T based). I remember there was some issue with getting the phones to register on the Cricket Network, but the Cricket agent fiddled with the phones for a minute and everything was fine. Both phones were used on the Cricket Network for about two years with no problems.

I upgraded to Samsung S7s this year. I simply took the Cricket SIM cards out of the S5s and put them in the S7s. No problems, everything worked fine. A relative needed a phone, so being a good person I offered one of my old S5s. The relative is a Walmart Family Mobile (T-Mobile Network) customer. In put her Walmart Family Mobile (WFM) SIM in the S5 and booted the phone. The S5 started normally, but when I tried to make a call, I got a "Not Registered on Network" error. The same happened with the other S5 as well.

After an hour or so on the phone with the WFM India call center, it was decided the WFM SIM must be bad. A new WFM SIM was sent and installed. No help, I still got the "Not Registered on Network" error. If the new WFM SIM is put in my S7, it works fine. If I put the Cricket SIM in the S5, it works fine, but the Walmart Family Mobile SIM will not work with either of my S5s.

I've done some deep diving in the forum abyss and have tried:
  • Getting the APN settings off the internet and hand installing.
  • Putting the WFM SIM in my S7 and then written down the resulting APN settings and transferring them to the S5.
  • Factory reset the S5 from the Backup and Reset menu.
  • Factory reset the S5 from the Android Recovery mode (also wiped the cache).
  • Tried various combination of switch taps, multiple SIM removal and re-insertions, battery removal & reinsertions.
  • Waving a dead chicken over the phone while closing my eyes and clicking my heels together, repeating "I hope this works, I hope this works".


I spent another hour on the phone with the WFM call center. They concluded the phones are faulty.

I went to T-Mobile and asked them to try a known working SIM card in my S5. Still would not register on network. They suggested that since the phone was on the Cricket network, it was somehow locked to the Cricket network. I found this hard to believe, but what the heck.

I went to Cricket and told them what T-Mobile had said. They indicated that only the company that produced the ROM can unlock the phone. Since the S5 is a T-Mobile phone, only T-Mobile could unlock it. However, since it had already been on the Cricket network, the phone is obviously unlocked. They tried the WFM SIM in one of their phones and it worked fine. They tried their Cricket SIM in the S5, and it worked fine. They put the WFM SIM back in the S5 and booted the phone. For a split second, Walmart Family Mobile flashed at the top of the screen and then disappeared, but the phone would still not register on the network. The Cricket agent said call Samsung or try Geek Squad.

I called Samsung. They said the phone is apparently working fine, the problem is with the networks, so they can't help.

I called Geek Squad, I explained the situation carefully. The Geek Squad Tech started explaining to me that the phone was locked by AT&T and I'd have to get AT&T to unlock it. I reminded the "Tech" that the phone is an SM-900T ROMed for T-Mobile (by T-Mobile), and it had been on Cricket, an AT&T based network, so obviously the phone was already unlocked, to which the "Tech" replied, then we obviously can't help you...click.

Out of curiosity, I went to AT&T to see if their SIM would work. I wanted to find out if the problem is specific to Cricket or AT&T. The AT&T agent was very helpful and installed a SIM card; the phone worked perfectly.

I am at my wits end. I have two working (and in very good condition) S5 T-Mobile phones that only work on an AT&T network. I'm thinking this must be a setting issue. Does anyone out there have a suggestion as to how this can be fixed?